Posts Tagged ‘quartz extreme in 10.6.4’

Ok boys and girls, this one was a major pain in the ass to figure out. Updating from either a vanilla, or iatkos s3 install from 10.6.x to 10.6.5 on the EP45-UD3P proved to be more trouble than it was worth (for me), but in the end I was able to get the full functionality back.

10.6.5 replaces IOUSB kexts as well as somewhere it disables Quartz Extreme, probably ousting one of the injectors. Modifying your plist with the <key>GraphicsEnabler</key> and repairing permissions did NOT work for me. After removing NVinject, NVenabler, and a few others and repairing as well did NOT work.

For usb functionality to come back, it was a simple fix, I ran Multibeast>Easybeast, repaired permissions and voila! back to business.

For kext installation you can simply drag and drop and sudo diskutil repairpermissions / in terminal if this doesn’t work, then try /sbin/fsck -fy , or diskutil verify / or  just use Kext Helper which is the “easy as sunday morning” installer for newbies and check the box for “repair permissions“. There is also a tonyx86 version called KextBeast, but personally I haven’t used it so I can’t say which is better.

So in my case, my Nvidia 9800GTX+ 512mb card had lost QE ability, though the proper resolutions were supported on boot, I couldn’t start FCP or any quartz reliant application, dock moved choppy as well as expose. Using the more hacker friendly site Kexts.com proved to be the most useful knowledge I could openly ask for on the web. While a lot of other sites pussyfooted (emphasis on “pussy”) discussion about hackintosh setups, at Kexts.com you can openly discuss your distro and setup. I literally went through every applicable option to re-enable the quartz on the card, it went as follows:

Nvidia vanilla kexts: didn’t work

Nvidia drivers (tweaked by tony): didn’t work

EasyGFX: worked on my i7 setup but not on my EP45-UD3P setup

NVEnabler by Krazubu: didn’t work and yeeesss I ran: ioreg -lw0 > NVEnabler_ioreg_dump_$USER.txt

x-darwin: didn’t work

NVEnabler – NVinject – Natit for 10.6.4: WORKED, however here’s the oddest part of this, when running the downloaded 10.6.4 package and updating from 10.6.3. I still lost quartz extreme. however updating to 10.6.5 from 10.6.4 then rolling back the kexts to 10.6.4 re-enabled quartz… funny isn’t it?

Not really to me. Frustrating to me more than anything else.

Now that the process has been ran through the washer, it’s a simple rinse and repeat for anyone else. And if you need help or if I lost you in the geek-speak, then feel free to drop a comment, I’ll be listening. I’m always listening, waiting and watching. Just kidding, that’s just plain creepy.

Cheers.